Delay in processing documents on LHDN due to site Maintenance

Incident Report for Pagero Service

Resolved

This maintenance has been resolved.
Posted Oct 31, 2025 - 06:25 CET

Investigating

Dear Customer,

The Malaysian flow is undergoing an unannounced maintenance by the correspondent tax authority and some documents might be affected until this maintenance is finished.

We're monitoring this closely and will share updates as we have them. Thank you for your patience and understanding.
Posted Oct 30, 2025 - 19:21 CET
This incident affected: Pagero Online.