Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 11, 2025 - 17:00 CEST
Scheduled
DocProcess has scheduled a maintenance on September 11th to improve the platform ou will not be able to access the DocProcess platform from 5 pm to 8 pm (CEST), therefore will not be able to submit documents during this timeframe.
All your submitted documents will be secured and processed as usual, once the platform is available again.
Thank you for your understanding and we remain at your disposal for further information.
Posted Sep 06, 2025 - 02:42 CEST
This scheduled maintenance affected: Partner (Pagero Online).